PDA

View Full Version : Error in zrm-reporter



rbartz
November 24th, 2006, 06:42 AM
I installed ZRM and it backs up correctly, however when I tried to use the reporter I get the following errors: (from /var/log/mysql-zrm/mysql-zrm-reporter.log)

WARNING: Backup root directory not specified, Assigning default value as /var/lib/mysql-zrm

On the CLI I get nothing, just goes to a new prompt.........

I have changed the backup directory to /backups/mysql-zrm and the backups are created there (eg. daily/20061124062026).

Any ideas why the reporter does not work?

R

paddy
November 25th, 2006, 03:41 PM
If you have changed backup root directory, you should pass --destionation parameter to
mysql-zrm-reporter (http://mysqlbackup.zmanda.com/index.php/mysql-zrm-reporter)command.

In your case it should be

mysql-zrm-report --destination /backups/mysql-zrm

Paddy

jamesg
December 28th, 2006, 11:17 AM
I am able to use ZRM without any obvious trouble. I have made several backups so far, and the main log file (mysql-zrm.log), the emails I have received and the HTML reports that get generated all seem to indicate that everything is fine. However, I keep getting:

WARNING: Backup root directory not specified

in file mysql-zrm-reporter.log, even though I have the following line in mysql-zrm.conf:

destination="/var/lib/mysql-zrm"

I tried doing backups with and without the quotes........same result. The command I am using to perform the backup:

mysql-zrm-scheduler --now --backup-set dailyrun

I also tried using the --destination parameter as described above............no help. ZRM says this is an invalid parameter.

Update: I ran...

mysql-zrm-reporter --where backup-set=dailyrun --show backup-status-info --destination=/var/lib/mysql-zrm

this morning. The output is correct (it shows the status of all my backups), but it still writes the same "WARNING: Backup root directory not specified..." message to file mysql-zrm-reporter.log.

Any ideas? Is this a problem I need to fix? Or is it a minor bug that will get fixed in the next release?

Thanks.

paddy
December 29th, 2006, 11:16 AM
Hi Jamesg,

Which version of MySQL ZRM are you using?

destination parameter in the mysql-zrm.conf (http://wiki.zmanda.com/index.php/Mysql-zrm.conf) does not require quotes.

mysql-zrm-scheduler (http://wiki.zmanda.com/index.php/Mysql-zrm-scheduler) reads the destination parameter from the mysql-zrm.conf.

mysql-zrm-reporter takes --destination as parameter and should not print the
WARNING. We will take a look.

Thanks,
Paddy

paddy
December 31st, 2006, 02:51 PM
We will remove the WARNING message from mysql-zrm-reporter in the next release. This warning message can be ignored.

Paddy

psynaptic
June 26th, 2009, 04:26 PM
I'm still experiencing this in version 2.1. Just thought I'd let you know.

uvdevnull
August 8th, 2011, 07:49 AM
... and in 2.2