PDA

View Full Version : "runtapes volumes already written" on FreeBSD with USB tape drive



kstrauser
November 4th, 2009, 08:19 AM
I'm using FreeBSD 8.0-RC2 (2009-10-27) and Amanda 2.6.1p1 (compiled from ports). I'm backing up to:



sa0: <QUANTUM DLT-V4 0A00> Removable Sequential Access SCSI-2 device


attached via USB, and using a stack of brand new tapes that we bought just for this. I keep getting this error in the dump and flush results:



The dumps were flushed to tape UnixBackup-10.
*** A TAPE ERROR OCCURRED: [runtapes volumes already written].
There are 32465M of dumps left in the holding disk.
They will be flushed on the next run.

The next tape Amanda expects to use is: UnixBackup-01.

FAILURE DUMP SUMMARY:
db1.daycos.com /usr/local/pgsql lev 2 FAILED "runtapes volumes already written"
db1.daycos.com /usr/local/pgsql lev 2 FAILED [too many taper retries]
db1.daycos.com /usr/local/pgsql lev 2: partial taper: Error writing filemark: Input/output error


The taper.debug log yields:



1257351569.949285: taper: warning: Got EIO on /dev/nsa0, assuming end of tape
1257351569.949345: taper: Device /dev/nsa0 error = 'No space left on device'
1257351569.949502: taper: Device /dev/nsa0 setting status flag(s): DEVICE_STATUS_VOLUME_ERROR
1257351580.311166: taper: Device /dev/nsa0 error = 'Error writing filemark: Input/output error'
1257351580.311257: taper: Device /dev/nsa0 setting status flag(s): DEVICE_STATUS_DEVICE_ERROR, and DEVICE_STATUS_VOLUME_ERROR
1257351580.311503: taper: device /dev/nsa0 ran out of space
1257351584.860231: taper: putresult: 4 PARTIAL
1257351584.860802: taper: getcmd: FILE-WRITE 00-00026 /amanda/20091031233001/db1.daycos.com._usr_local_pgsql.2 db1.daycos.com /usr/local/pgsql 2 20091031233001 0
1257351584.875507: taper: putresult: 26 REQUEST-NEW-TAPE
1257351584.876098: taper: getcmd: NO-NEW-TAPE "runtapes volumes already written"
1257351584.883041: taper: Device /dev/nsa0 error = 'Error reading Amanda header'
1257351584.883085: taper: Device /dev/nsa0 setting status flag(s): DEVICE_STATUS_VOLUME_UNLABELED, and DEVICE_STATUS_VOLUME_ERROR
1257351584.884471: taper: putresult: 10 FAILED
1257351584.884933: taper: getcmd: QUIT
1257351584.884960: taper: putresult: 2 QUITTING


I've tried swapping with an identical drive off another machine to see if it was a hardware problem, but I'm still getting the same errors. No hardware faults are showing up in the system logs on the machine. I'm at a loss for what to try next. Any suggestions?

milesje
November 5th, 2009, 04:06 AM
I am also have a simular problem, when running amstatus after a dump is finished I am seeing this

computer.domain.net:/RAID/Repository 0 7415m dump done (4:35:24), wait for writing to tape
computer.domain.net:/home 1 57m failed to tape: runtapes volumes already written (5:27:15)

I am at a loss as to the problem. I am using new tapes I have cleaned the drive (Exabyte VXA-320). I do not see any error logs in /temp/amanda or in /var/logs/amanda.