PDA

View Full Version : Problem trying test backups with single server configuration



sanman
November 8th, 2006, 08:06 AM
Hi.

My problem is probably very simple in which case I apologise now. I have installed amanda 2.5.1p1 on a single Fedora Core 5 server and tried to configure so that I simply back up files from this server to a temporary directory (the plan is to archive those files elsewhere). When I run "amcheck daily" as user amanda I get the following error:

Amanda Tape Server Host Check
-----------------------------
Holding disk /backups/amanda/daily: 3131912 KB disk space available, using 3029512 KB
slot 3: read label `daily3', date `X'
NOTE: skipping tape-writable test
Tape daily3 label ok
NOTE: host info dir /usr/local/etc/amanda/daily/curinfo/serena.mosol.co.uk does not exist
NOTE: it will be created on the next run.
NOTE: index dir /usr/local/etc/amanda/daily/index/serena.mosol.co.uk does not exist
NOTE: it will be created on the next run.
Server check took 0.117 seconds

Amanda Backup Client Hosts Check
--------------------------------
WARNING: serena.mosol.co.uk: selfcheck request failed: Connection refused
Client check: 1 host checked in 10.008 seconds, 1 problem found

(brought to you by Amanda 2.5.1p1)

The amcheck log contains the following information (I won't paste it all unless requested to reduce clutter)

amcheck-clients: time 0.001: connect_portrange: connect from 0.0.0.0.516 failed
amcheck-clients: time 0.001: connect_portrange: connect to 127.0.0.1.10080 failed: Connection refused
amcheck-clients: stream_client: Could not bind to port in range 512-1023.
amcheck-clients: time 0.001: connect_port: Try port 1025: Available -
amcheck-clients: time 0.002: connect_portrange: connect from 0.0.0.0.1025 failed
amcheck-clients: time 0.002: connect_portrange: connect to 127.0.0.1.10080 failed: Connection refused
amcheck-clients: stream_client: Could not bind to any port: Connection refused
security_seterror(handle=0x8c84098, driver=0x3cc140 (BSDTCP) error=Connection refused)



I have not run any of the daemons by hand: if I try to run amandad as root, the program seems to run for a while and then end with nothing bad in the log.

I believe I have configured ~amanda/daily/amanda.conf correctly - i am trying to use disk backups rather than tape and thus have the following within the file


runtapes 1 # number of tapes to be used in a single run of amdump
tpchanger "chg-disk" # the tape-changer glue script
tapedev "file:/backups/amanda/daily" # the no-rewind tape device to be used
rawtapedev "/dev/null" # the raw device to be used (ftape only)
holdingdisk hd1 {
comment "main holding disk"
directory "/backups/amanda/daily" # where the holding disk is
use -100 Mb # how much space can we use on it
# a non-positive value means:
# use all space but that value
chunksize 1Gb # size of chunk if you want big dump to be
# dumped on multiple files on holding disks
# N Kb/Mb/Gb split images in chunks of size N
# The maximum value should be
# (MAX_FILE_SIZE - 1Mb)
# 0 same as INT_MAX bytes
}
infofile "/usr/local/etc/amanda/daily/curinfo" # database DIRECTORY
logdir "/usr/local/etc/amanda/daily" # log directory
indexdir "/usr/local/etc/amanda/daily/index" # index directory
tapelist "/usr/local/etc/amanda/daily/tapelist" # list of used tapes



I have tried running "amdump daily" in case I can ignore the amcheck error (I am an optimist) but that does not seem to do anything. Can anyone tell me what I am doing wrong? Thank you in advance

Dave

ktill
November 8th, 2006, 10:35 AM
Hi,

is /tmp/amanda/client/daily/amanda.*.debug created? If so, any error?

is selinux running? Run sestatus to check.

--Kevin Till

sanman
November 8th, 2006, 11:46 AM
Hi. Thanks for looking at this. If I type

sestatus|grep -i selinux

it says

SELinux status: enabled
SELinuxfs mount: /selinux

As for the debug logs, I have been clearing them out regularly for clarity. I have seen /tmp/amanda/client/*debug files but since my last spring clean, if I run amcheck daily and amdump daily I only get files in /tmp/amanda/server. The amcheck debug file gives the errors mentioned before.

One thing - the server had originally the name dpfc4 and I renamed this to serena. However, if I type

amadmin x version |grep -i server
I get
defs: DEFAULT_SERVER="dpfc4" DEFAULT_CONFIG="DailySet1"
DEFAULT_TAPE_SERVER="dpfc4" HAVE_MMAP HAVE_SYSVSHM
Is it possible that amanda routines are trying to connect to the non existant dpfc4? I have added dpfc4 to /etc/hosts as the same machine as serena, so this hostname is resolvable.

Any ideas? Thank you

ktill
November 8th, 2006, 01:26 PM
Hi,

if there is no /tmp/amanda/amandad/amandad.*.debug file, it indicates that amandad
cannot be started.

I suggest disable selinux, make sure amcheck and amdump works and fix the configuration if necessary.

Then (if selinux is required), turn selinux to permissive mode. See what amanda operation is disallowed by selinux. Then use audit2allow to allow the particular operation. Rebuild selinux policy and install.

Hope this helps!

--Kevin Till

Grubsy
November 8th, 2006, 05:28 PM
Do you have anything in you .amandahosts file?

I have the following:

more /var/lib/amanda/.amandahosts

myserver.mydomian.com root
myserver.mydomian.com amanda

Also check the permissions maybe:

-rw------- 1 amanda disk 330 Nov 9 09:10 .amandahosts

sanman
November 9th, 2006, 01:00 AM
Hi

Thank you both for suggestions. Here is the current state of play. I tried to turn selinux off (I don't need it in this environment) using the command

setenforce 0

and changing /etc/sysconfig/selinux so that SELINUX=disabled. Though sestatus says selinux is still enabled, it is now set to passive. I guess I need to reboot for this to take effect (I shall try that tomorrow when I am physically at the computer if I don't resolve the problem before then. As an aside, the "security level configuration GUI says that selinux is not enabled but that modification required reboot). amcheck currently returns the same error, so if selinux is the problem then I guess the reboot is the required option ... I shall report on that tomorrow.

In my .amandahosts file (which is situated in ~amanda, owned by amanda and has permissions of 600 I have the following entries

serena.mydomain.com amanda amdump
serena.mydomain.com root amindexd amidxtaped

If I ping serena.mydomain.com I get a response on the 127.0.0.1 address. If I modify .amandahosts to the following entry

serena.mydomain.com amanda
serena.mydomain.com root

I get the same error from amcheck.

Thanks again for the help - it is appreciated. :)

sanman
November 10th, 2006, 12:53 AM
Hi. Well, I have just rebooted the server but get the same problems. Typing sestatus tells me that selinux is disabled. Any other ideas? Thanks