PDA

View Full Version : Problem with amcheck



jeffm
November 2nd, 2006, 11:25 AM
when I run amcheck DailySet1 I get a error that says
ERROR: NAK mail: user amandabackup from backserv is not allowed to execute the service noop: Please add "amdump" to the line in /var/lib/amanda/.amandahosts
Client check: 2 hosts checked in 0.125 seconds, 1 problem found

On my mail client this is my .amandahosts file

mail amandabackup amdump amindexd amidxtaped
backserv amandabackup amandabackup amdump

Please help

paddy
November 2nd, 2006, 11:31 AM
The entry "backserv amandabackup amandabackup amdump" should be
"backserv amandabackup amdump"

Use FQDN of the server in .amandahosts.

Paddy

jeffm
November 2nd, 2006, 11:41 AM
from the client

mail amandabackup amdump amindexd amidxtaped
backserv amandabackup amdump

PING backserv (192.168.0.113) 56(84) bytes of data.
64 bytes from backserv (192.168.0.113): icmp_seq=0 ttl=64 time=1.01 ms
64 bytes from backserv (192.168.0.113): icmp_seq=1 ttl=64 time=0.150 ms
64 bytes from backserv (192.168.0.113): icmp_seq=2 ttl=64 time=0.168 ms

/etc/hosts
192.168.0.113 backserv

I still get the error

paddy
November 2nd, 2006, 11:45 AM
Check the xinetd configuration.

Possible ways to fix the problem is described in amcheck troubleshooting (http://wiki.zmanda.com/index.php/Amcheck:_access_as_localuser_not_allowed_from_remo teuser%40remotehost) page in the wiki.

Please note this page has old syntax for xinetd files and .amandahosts files. For 2.5.1 syntax, please see http://wiki.zmanda.com/index.php/Configuring_bsd/bsdudp/bsdtcp_authentication

Paddy

jeffm
November 2nd, 2006, 11:50 AM
this is what mine looks like

service amanda
{
disable = no
socket_type = dgram
protocol = udp
wait = yes
user = amandabackup
group = disk
groups = yes
server = /usr/lib/amanda/amandad
}

paddy
November 2nd, 2006, 11:54 AM
Example from http://wiki.zmanda.com/index.php/Configuring_bsd/bsdudp/bsdtcp_authentication page:

service amanda
{
only_from = amandaserver.company.com
socket_type = dgram
protocol = udp
wait = yes
user = amandabackup
group = disk
groups = yes
server = /usr/lib/amanda/amandad
server_args = -auth=bsd amdump
disable = no
}

"only_from" is optional.

Paddy

jeffm
November 2nd, 2006, 11:59 AM
The only thing that is missing was the

server_args = -auth=bsd amdump

my /etc/xinetd.d/amandaclient

service amanda
{
socket_type = dgram
protocol = udp
wait = yes
user = amandabackup
group = disk
groups = yes
server = /usr/lib/amanda/amandad
server_args = -auth=bsd amdump
disable = no
}


Still does not work

jeffm
November 2nd, 2006, 11:59 AM
I did do a service reload

jeffm
November 2nd, 2006, 12:12 PM
It is working now. I had a bad char in the hosts file.

Thanks