View Full Version : Problems with HP Storageworks 1/8 G2

August 18th, 2009, 07:28 AM

I am in the process of building a new backup server to replace the ageing current setup. I've gone for an HP Storageworks 1/8 G2 with LTO4 (1760) SAS loader connected to a host running RHEL5.

I'm running Amanda 2.6.1p1.

The problem I'm having is that I'm periodically getting tape errors

1250600709.328466: taper: warning: Got EIO on /dev/nst0, assuming end of tape
1250600709.328521: taper: Device /dev/nst0 error = 'No space left on device'
1250600709.328597: taper: Device /dev/nst0 setting status flag(s): DEVICE_STATUS_VOLUME_ERROR
1250600717.388371: taper: device /dev/nst0 ran out of space

But the tape is nowhere near the end. Having Googled around I've tried cleaning the drive and tried various tapes (all new out of the cellophane). But to no avail.

I've run various read/write tests on the drive using the HP Tape Tools utility and get no errors. I can also write to the drive using dd and tar without problems. It seems to only be taper that has problems.

Is anyone else successfully using this drive model?



August 18th, 2009, 08:01 AM
Just a quick update. I see the following in the system log at the time of the error.

Aug 18 13:14:45 lon-wal-bkup-1 kernel: mptbase: ioc0: LogInfo(0x31120403): Originator={PL}, Code={Abort}, SubCode(0x0403)
Aug 18 13:14:45 lon-wal-bkup-1 kernel: st0: Error 80000 (sugg. bt 0x0, driver bt 0x0, host bt 0x8).

Which would suggest a hardware issue - if it wasn't for the fact that everything else works...

August 19th, 2009, 01:57 AM
Solved. Turns out the rear door of the rack was pressing against the cable.

January 8th, 2010, 11:16 AM
Were you using the HP StorageWorks 1/8 G2 LTO-3 Ultrium 920 SAS Tape Autoloader?

I am evaluating this hardware for use with Amanda