PDA

View Full Version : Windows Server 2008 "Server Validation Failed. Please register server with client."



mboudro
August 15th, 2009, 11:48 AM
I installed the ZWC Client successfully and can see the service running. Additionally, I verified that the DNS is functioning properly and the DNS name of the Amanda server is properly located within the registry entries of the ZWC. When running amcheck/amdump, I receive the error "Server validation Failed. Please register server with client." I've done a significant amount of searching and troubleshooting already and have not been able to solve the problem.

I also tried running amcheck with the Server 2008 firewall disabled and received the same result. Here is some of the log entries:


4136:3348:13:40:271:CZWCJobHandler::ExecuteJob : Job Type = 3
4136:3348:13:40:271:CAmandaStateManager : Changing the service state to SRV_SERVER_ACK_WAIT
4136:3348:13:40:474:CZWCJobHandler::ExecuteJob : Job Type = 5
4136:3348:13:40:474:CZWCJobHandler::ExecuteJob : Job Type = 21
4136:3348:13:40:474:CZWCJobHandler::ExecuteJob : Job Type = 1
4136:3348:13:40:474:CZWCJobHandler::ExecuteJob : Job Type = 3
4136:3348:13:40:474:CZWCJobHandler::ExecuteJob : Job Type = 6
4136:3348:13:40:474:ZWC Failure error code: 2
4136:3348:13:40:474:FS: NTFS: GetAttributes: GetAttributes of D:\
4136:3348:13:40:474:FS: NTFS: GetAttributes: GetAttributes is Sucessful
4136:3348:13:40:474:CZWCJobHandler::ExecuteJob : Job Type = 7
4136:3348:13:40:474:CZWCJobHandler::ExecuteJob : Job Type = 8
4136:3348:13:40:474:CAmandaStateManager : Changing the service state to SRV_SERVER_ACK_WAIT
4136:5080:13:40:474:Got error while reading from socket
4136:5080:13:40:474:ZWC Failure error code: 0
4136:5080:13:40:474:RemoveStaleClient : Last error code is
4136:5080:13:40:474:An established connection was aborted by the software in your host machine.

4136:5080:13:40:474:Communication Layer : Connection closed by server.

Any ideas? The server properly backed up two other Linux-based servers, so I know the server is running properly.

Thanks in advance for your help.

prashant
August 17th, 2009, 02:08 AM
Hi,
Since, you have already registered the Amanda Server in the ZWC Client, we would need log files to debug the issue.

1. Set the log level to 5 by setting following registry key
HKEY_LOCAL_MACHINE\SOFTWARE\ZMANDA\ZWC\1.0\Debug\L ogLevel
2. Restart ZWCService.

Run Verify Client.

Login to the Windows client machine using Administrator user. Go to "Start Menu > Programs > Zmanda Community Edition" and click on "ZWC Support". This will collect the client logs.

On the Amanda server, run /opt/zmanda/amanda/bin/zm-support --config <configname>

Please send us both the client and server log files.

Regards,
Prashant

mboudro
August 17th, 2009, 09:49 AM
Well, the problem resolved itself. I ran the check/backup this morning and it functioned properly. No settings changed since the problem occurred.

Nevertheless, thanks for your help.

frigoref
October 3rd, 2012, 03:42 PM
Hey, I am having the same problem with the Windows Client and it did not solve itself.

I have a linux computer working great as amanda server for another linux computer, but does produce the "Server validation Failed. Please register server with client." message on amcheck.
I have done so far:
- changed the value of HKEY_LOCAL_MACHINE\SOFTWARE\Zmanda\ZWC\1.0\Install \BackupUser and RecoveryUser to backup (as this is the user name on the amanda server that does the backup)
- created a dumptype entry:
define dumptype dailyWIN {
global
comment "daily dumptype"
compress client fast
program "DUMP"
strategy standard
priority high
}
- add to disklist an entry of the format " C:/Users/XXX/Desktop dailyWIN"
- changed the Service "ZWC Service" to log on as ".\backup"
- I also created a user backup on my windows machine

What did I miss?

xHan
October 3rd, 2012, 03:50 PM
Hey, I am having the same problem with the Windows Client and it did not solve itself.

I have a linux computer working great as amanda server for another linux computer, but does produce the "Server validation Failed. Please register server with client." message on amcheck.


So you have two clients, a Linux and a Windows?
Is "Server validation Failed. Please register server with client." about your Linux or Windows client?

frigoref
October 7th, 2012, 08:33 AM
Yes, I have two clients. One with Linux (where the backup works fine) and one with Windows.
I get the following
"ERROR: 192.168.1.40: Server validation Failed. Please register server with client.
Client check: 2 hosts checked in 6.140 seconds. 1 problem found."

The amcheck debug file seems fine (just the last lines):
"Sun Oct 7 17:25:08 2012: amcheck-clients: make_socket opening socket with family 2
Sun Oct 7 17:25:08 2012: amcheck-clients: connect_port: Try port 516: available - Success
Sun Oct 7 17:25:08 2012: amcheck-server: Spawning "/usr/lib/amanda/amcheck-device /usr/lib/amanda/amcheck-device DailySet1" in pipeline
Sun Oct 7 17:25:08 2012: amcheck-clients: connected to 192.168.1.1:10080
Sun Oct 7 17:25:08 2012: amcheck-clients: our side is 0.0.0.0:516
Sun Oct 7 17:25:08 2012: amcheck-clients: try_socksize: send buffer size is 65536
Sun Oct 7 17:25:08 2012: amcheck-clients: try_socksize: receive buffer size is 65536
Sun Oct 7 17:25:08 2012: amcheck-clients: tcpm_send_token: data is still flowing
Sun Oct 7 17:25:08 2012: amcheck-clients: security_getdriver(name=bsdtcp) returns 0x7f01fbd0f9c0
Sun Oct 7 17:25:08 2012: amcheck-clients: security_handleinit(handle=0x2372460, driver=0x7f01fbd0f9c0 (BSDTCP))
Sun Oct 7 17:25:08 2012: amcheck-clients: security_streaminit(stream=0x237deb0, driver=0x7f01fbd0f9c0 (BSDTCP))
Sun Oct 7 17:25:08 2012: amcheck-clients: make_socket opening socket with family 2
Sun Oct 7 17:25:08 2012: amcheck-clients: connect_port: Try port 516: available - Success
Sun Oct 7 17:25:08 2012: amcheck-clients: connected to 192.168.1.40:10080
Sun Oct 7 17:25:08 2012: amcheck-clients: our side is 0.0.0.0:516
Sun Oct 7 17:25:08 2012: amcheck-clients: try_socksize: send buffer size is 65536
Sun Oct 7 17:25:08 2012: amcheck-clients: try_socksize: receive buffer size is 65536
Sun Oct 7 17:25:08 2012: amcheck-clients: tcpm_send_token: data is still flowing
Sun Oct 7 17:25:09 2012: amcheck-clients: security_getdriver(name=bsdtcp) returns 0x7f01fbd0f9c0
Sun Oct 7 17:25:09 2012: amcheck-clients: security_handleinit(handle=0x2373ab0, driver=0x7f01fbd0f9c0 (BSDTCP))
Sun Oct 7 17:25:09 2012: amcheck-clients: security_streaminit(stream=0x2385f10, driver=0x7f01fbd0f9c0 (BSDTCP))
Sun Oct 7 17:25:09 2012: amcheck-clients: security_close(handle=0x236ec00, driver=0x7f01fbd0f9c0 (BSDTCP))
Sun Oct 7 17:25:09 2012: amcheck-clients: security_stream_close(0x2375e50)
Sun Oct 7 17:25:10 2012: amcheck-server: userbad: 0
Sun Oct 7 17:25:10 2012: amcheck-server: confbad: 0
Sun Oct 7 17:25:10 2012: amcheck-server: tapebad: 0
Sun Oct 7 17:25:10 2012: amcheck-server: disklow: 0
Sun Oct 7 17:25:10 2012: amcheck-server: logbad: 0
Sun Oct 7 17:25:10 2012: amcheck-server: infobad: 0
Sun Oct 7 17:25:10 2012: amcheck-server: indexbad: 0
Sun Oct 7 17:25:10 2012: amcheck-server: pgmbad: 0
Sun Oct 7 17:25:14 2012: amcheck-clients: security_getdriver(name=bsdtcp) returns 0x7f01fbd0f9c0
Sun Oct 7 17:25:14 2012: amcheck-clients: security_handleinit(handle=0x236ec00, driver=0x7f01fbd0f9c0 (BSDTCP))
Sun Oct 7 17:25:14 2012: amcheck-clients: security_streaminit(stream=0x2375e50, driver=0x7f01fbd0f9c0 (BSDTCP))
Sun Oct 7 17:25:14 2012: amcheck-clients: security_close(handle=0x2372460, driver=0x7f01fbd0f9c0 (BSDTCP))
Sun Oct 7 17:25:14 2012: amcheck-clients: security_stream_close(0x237deb0)
Sun Oct 7 17:25:14 2012: amcheck-clients: security_close(handle=0x2373ab0, driver=0x7f01fbd0f9c0 (BSDTCP))
Sun Oct 7 17:25:14 2012: amcheck-clients: security_stream_close(0x2385f10)
Sun Oct 7 17:25:14 2012: amcheck-clients: security_close(handle=0x236ec00, driver=0x7f01fbd0f9c0 (BSDTCP))
Sun Oct 7 17:25:14 2012: amcheck-clients: security_stream_close(0x2375e50)
Sun Oct 7 17:25:14 2012: amcheck: pid 1627 finish time Sun Oct 7 17:25:14 2012"

Does that mean it has something to do with the Windows user or the folder permissions?

prashant
October 8th, 2012, 10:32 PM
Hi,

1. You will have add 'backup' user to 'Administrators', 'Backup Operators' & 'Users' groups.
2. Also give 'backup' user 'Full Control' permissions on the 'ZWC' installation directory.
3. Using the ZWCConfig Utility, increase the log level to '5' and try validation again. If it fails, please paste the contents of LogFile.txt.

Regards,
Prashant

frigoref
October 24th, 2012, 12:04 PM
I am terribly sorry!!! I used the wrong IP address -.-
This problem is solved ..