PDA

View Full Version : Error: No index records for disk for specified date



bjorn72
October 15th, 2006, 01:26 PM
Hi,
I'm a newbie trying to make a test backup of my /home-directory (small one, few users) to vtapes. The amdump seems to be working, with reports being sent indicating no errors, but when I try to recover the files I'm presented an error message stating that no index exists for the date specified.

I have localhost configured both as server and client, and I have tried to follow the Quickstart in the Wiki as close as possible.

I've labeled the vtape with

# amlabel daily DailySet100

This is a dump of the amrecover command output:

[root@localhost test]# amrecover daily
AMRECOVER Version 2.4.5p1. Contacting server on localhost ...
220 localhost AMANDA index server (2.4.5p1) ready.
200 Access OK
Setting restore date to today (2006-10-15)
200 Working date set to 2006-10-15.
Scanning /dumps/amanda...
200 Config set to daily.
200 Dump host set to localhost.
Trying disk / ...
Trying disk rootfs ...
Can't determine disk and mount point from $CWD '/test'
amrecover> listdisk
200- List of disk for host localhost
201- /home
200 List of disk for host localhost
amrecover> setdisk /home
200 Disk set to /home.
No index records for disk for specified date
If date correct, notify system administrator
amrecover>
If someone could please shed some light over this, I'd really appreciate it!
Thanks in advance,
/Björn Jonsson

ppragin
October 16th, 2006, 07:53 AM
1.Check your dumptypes and make sure they include the line:
index yes

2. run amdump again
3. run amrecover and check if you can see indexes now

Thanks
Pavel