PDA

View Full Version : Centos server with getnoo client



efram
May 11th, 2009, 06:49 AM
Hi,

I had recently installed amanda-backup_server-2.6.1p1-1.rhel5 server on a Centos 5.3 machine.
I'm traying to backup two gentoo clients amanda-2.6.0_p2-r4 that were installed via portage.
amcheck give me the following error:

Amanda Backup Client Hosts Check
--------------------------------
WARNING: gentoo1.mydomain selfcheck request failed: timeout waiting for ACK
WARNING: gentoo2.mydomain: selfcheck request failed: timeout waiting for ACK
Client check: 3 hosts checked in 30.024 seconds. 2 problems found.
(brought to you by Amanda 2.6.1p1)

The xinetd in the amanda server is:
service amanda
{
disable = no
# flags = IPv6
socket_type = stream
protocol = tcp
wait = no
user = amandabackup
group = disk
groups = yes
server = /usr/libexec/amanda/amandad
server_args = -auth=bsdtcp amdump amindexd amidxtaped
}


while in the clients is:
service amanda
{
socket_type = dgram
protocol = udp
wait = yes
user = amanda
group = amanda
groups = yes
server = /usr/libexec/amanda/amandad
disable = no
}


I had created two new dumptypes as follow:
define dumptype comp-root-tar-gentoo {
root-tar
comment "Root partitions with compression and bsd auth"
compress client fast
auth "bsd"
}
define dumptype comp-user-tar-span-gentoo {
user-tar-span
compress client fast
auth "bsd"
}

When I run at the clients amandad manually it waits 60 seconds and close itself without errors, if I use "amandad -auth=bsdtcp it close closes itself intermediately.

In /var/log/messages at the clients all that I see is:
xinetd[3564]: FAIL: amanda address from=x.x.x.x
xinetd[3531]: START: amanda pid=3564 from=x.x.x.x
xinetd[3531]: EXIT: amanda status=0 pid=3564 duration=0(sec)

The amandahosts file at the clients:
gentoo1 amanda amdump
bkpsrv01.mydomain amanda amdump
bkpsrv01.mydomain amandabackup amdump
bkpsrv01 amanda amdump
bkpsrv01 amandabackup amdump

I could not find any log to check at the client side.
May be there is some argument to pass to amandad in order to see what is happening?

Thanks

efram
May 12th, 2009, 05:08 AM
I finally solved the problem.

I just added the line "only_from = 0.0.0.0" to xinet.d/amanda and now it works.

Thanks

martineau
May 12th, 2009, 05:12 AM
I finally solved the problem.

I just added the line "only_from = 0.0.0.0" to xinet.d/amanda and now it works.

Thanks

It allow anybody on the internet to backup your machine, you should list only the amanda server