PDA

View Full Version : incremental backups showing backup size of 0.00MB



das_jojoba
April 1st, 2009, 02:22 PM
All,

Anyone else having issues with incrementals showing a backup-size of 0.00MB? I'm trying to run a daily full, with incrementals every half hour.

The email shows that we are getting successful backups, but the backup-size shows 0.00MB. Obviously I am a bit nervous about trusting backups that are showing 0 size.

The only thing I see when running with --verbose that may mean something is that tar can't stat the relay-log.info file. When running a full, this doesn't seem to be an issue.

If anyone else has seen this, please let me know. I'd love to hear that this is safe to ignore, or that someone else has resolved this.

zmanda_jacob
April 1st, 2009, 02:37 PM
If you cd to /<destination directory>/<timestamp> and you look at the size of the file backup_data, how big is it?

How big do you think your binary logs are? If you want to see what size the binary logs are that were backed up, cd to the above directory, rename backup_data to bd.tgz, and then run:

tar zxvf bd.tgz

It will unpack the binary logs that were backed up. If they're small, that would explain why it says 0.00.

das_jojoba
April 1st, 2009, 03:19 PM
The binlog files are 212 each (I'm assuming kilobytes, perhaps incorrectly). The index file is 23 lines and 703 characters, and it's showing a size of 703. I've seen other examples where the compressed backup size is 0.00, but the backup-size is 0.03 in examples that people have posted.