PDA

View Full Version : Broken Pipe error during install



exitcomestothis
March 18th, 2009, 09:09 AM
When I try to install the current version of zrm-mysql, I get this weird error.
dpkg -i mysql-zrm_2.1_all.deb
(Reading database ... 34068 files and directories currently installed.)
Unpacking mysql-zrm (from mysql-zrm_2.1_all.deb) ...
dpkg: error processing mysql-zrm_2.1_all.deb (--install):
trying to overwrite `/usr/share/mysql-zrm/plugins/lvm-snapshot.pl', which is also in package mysql-zrm-client
dpkg-deb: subprocess paste killed by signal (Broken pipe)
Errors were encountered while processing:
mysql-zrm_2.1_all.deb

Currently running Debian Lenny/sid Any help with this would be greatly appreciated.

paddy
March 18th, 2009, 10:05 AM
When I try to install the current version of zrm-mysql, I get this weird error.
dpkg -i mysql-zrm_2.1_all.deb
(Reading database ... 34068 files and directories currently installed.)
Unpacking mysql-zrm (from mysql-zrm_2.1_all.deb) ...
dpkg: error processing mysql-zrm_2.1_all.deb (--install):
trying to overwrite `/usr/share/mysql-zrm/plugins/lvm-snapshot.pl', which is also in package mysql-zrm-client
dpkg-deb: subprocess paste killed by signal (Broken pipe)
Errors were encountered while processing:
mysql-zrm_2.1_all.deb

Currently running Debian Lenny/sid Any help with this would be greatly appreciated.

You need either mysql-zrm package or mysql-zrm-client package (not both). If this machine is going to be ZRM server, please uninstall mysql-zrm-client and install mysql-zrm package.

Paddy

exitcomestothis
March 18th, 2009, 10:20 AM
Thanks! I don't know how the client got installed on this server, but after I removed it (dpkg -r mysql-zrm-client), it installed just fine! Thank you so much!