View Full Version : Multiple site configuration woes

September 20th, 2006, 07:45 AM
I have 4 sites (unique separate parts of the filesystems) on the same server that I need backed up. I placed all the pertinent files in separate directories with different site names and have configured it all to run at separate times. I need full backups of these separate file systems everyday. My tape changer was discovered with the “tapetype” command. It is a 10-tape changer. - VERSION="Amanda-2.5.0" - Can you please check my logic as the backups are not working as I expected.
“Site 1” amanda.conf:

dumpcycle 1
runspercycle 1
tapecycle 1 tapes
holdingdisk hd1 {
comment "main holding disk"
directory "/logs/amandaholding"
use -100 Mb
define dumptype nocomp-main-tar {
program "GNUTAR"
comment "Prod server backups"
compress none
dumpcycle 0
exclude list "/usr/local/etc/amanda/nocbak/exclude.gtar"
priority high
“Site 1” chg-multi.conf

multieject 0
gravity 0
needeject 1
ejectdelay 360
firstslot 1 – I modified this “first slot lastslot” so that amanda would only use the 1 st and 2nd slot for this site backup (?)
lastslot 2 – I will use the other slots for other separate site backups
slot 1 /dev/nst0
slot 2 /dev/nst0
slot 3 /dev/nst0
slot 4 /dev/nst0
slot 5 /dev/nst0
slot 6 /dev/nst0
slot 7 /dev/nst0
slot 8 /dev/nst0
slot 9 /dev/nst0
slot 10 /dev/nst0

The other 3 sites are set up identically but they use different slots on the tape changer.
Also, the other sites slotted tapes are labeled for their own named backups

Thanks in advance