View Full Version : ftp error

January 20th, 2009, 06:09 PM

When I am trying to start an FTP backup, the log file shows this:
2009-01-20 19:05:24 User shocked requested backup of mydomain.com (mydomain.com)
2009-01-20 19:05:24 mydomain.com: Couldn't create new FTP object

What would cause the "Couldn't create new FTP object" error?

Thank you

January 22nd, 2009, 09:31 AM
hello there,

The error message you're seeing is a result of the bundled CPAN modules.

The good news is that they're installed correctly.

The bad news is that your ftp configuration is not set correctly, or the server is inaccessible. The FTP object establishes a connection at its creation time and throws that error if it cannot connect.

Can you verify your ability to connect with the parameters entered via the web interface?

January 22nd, 2009, 09:48 AM

Thank you for the reply. I am still getting the same error. I have tried this from the backuppc machine:

# ftp mydomain.com
Connected to mydomain.com.
220 ProFTPD 1.3.1 Server (mydomain.com) [xx.xx.xx.20]
Name (mydomain.com:root): ftp_username_here
331 Password required for ftp_username_here
230 User ftp_username_here logged in
Remote system type is UNIX.
Using binary mode to transfer files.
ftp> quit
221 Goodbye.

I reset the ftp password on backuppc to make sure it is correct, and it is. the exact error is still:
2009-01-22 10:43:46 User myname requested backup of mydomain.com (mydomain.com)
2009-01-22 10:43:46 mydomain.com: Couldn't create new FTP object

Is there anything else I can troubleshoot?

January 22nd, 2009, 10:22 AM
Could you please post your backup client's .pl configuration script? I'd like to take a look at it.

January 22nd, 2009, 10:36 AM
file paste:
$Conf{FtpPasswd} = 'our_password';
$Conf{FtpUserName} = 'our_username';
$Conf{XferMethod} = 'ftp';
$Conf{PingMaxMsec} = 200;
$Conf{FtpShareName} = [

just so you know.. the pw and username were 100% correct.

January 22nd, 2009, 12:25 PM
Have any pings to the server succeeded? I want to make sure that this isn't a connection issue.

Could you try setting $Conf{ClientNameAlias} to the appropriate hostname?

January 22nd, 2009, 12:46 PM

Yes, the pings succeed because it said they were over 20ms, which is why I raised the limit to 200.

As for adding "$Conf{ClientNameAlias}"

I did add it to the .pl file I pasted above, and reloaded backuppc. It still gives the same error.

January 27th, 2009, 08:32 AM
Any thoughts?

February 18th, 2010, 08:47 AM
i get the same error, didn't found anything around google... any idea?