PDA

View Full Version : Trouble building 2.6.0p2 rpm from src



smartin52000
December 17th, 2008, 11:41 AM
I'm running centOS 4 X86_64. I've download the "amanda-2.6.0p2.tar.gz" to the /usr/src directory. When I run "rpmbuild -tb amanda-2.6.0p2.tar.gz" I get the following errors:

rpmbuild -tb amanda-2.6.0p2.tar.gz
error: parse error in expression
error: /usr/src/redhat/SPECS/amanda.spec:113: parseExpressionBoolean returns -1
error: Name field must be present in package: (main package)
error: Version field must be present in package: (main package)
error: Release field must be present in package: (main package)
error: Summary field must be present in package: (main package)
error: Group field must be present in package: (main package)
error: License field must be present in package: (main package)

Any help in pointing me in the right direction would be most appreciated.

Thanks

pyeatman
December 17th, 2008, 05:21 PM
I'm only familiar with using rpmbuild with an *.src.rpm file.

Have you tried building with configure, make, make install (INSTALL readme in top level of source code)? Have you tried a package such as at http://www.zmanda.com/download-amanda.php?
Paul