PDA

View Full Version : Incremental backup always emails despite configuring otherwise



lylo
November 9th, 2008, 02:07 AM
Hi there

I'm using Zmanda v1 for incremental backups. I have removed the 'mailto=' line from my configuration file (I use RSS for updates), but I am still receiving emails! Is this a bug or is there some other configuration I need to do to turn them off?

Many thanks

kulkarni_mangesh
November 9th, 2008, 08:07 PM
Have you set "mailto" in "/etc/mysql-zrm/mysql-zrm.conf", which is normally treated as global config ?

lylo
November 10th, 2008, 02:27 AM
Ah yes, removing this has fixed the problem, thanks!

kalexe
March 23rd, 2009, 08:34 AM
If we need to set it in the global config, then how can I get email from one backup and not from another?

lylo
April 20th, 2009, 03:59 AM
I have a further question on this thread.

I am now using a single configuration for both my daily and incremental (every 15 minutes) backups. I would like the daily run to send me an email, whereas I don't want an email for the incremental run.

Is it possible to specify "no email" from the command line when I schedule my incremental run? From what I've read there is no way to do this at the moment.

kkg
April 20th, 2009, 04:08 AM
I have a further question on this thread.

I am now using a single configuration for both my daily and incremental (every 15 minutes) backups. I would like the daily run to send me an email, whereas I don't want an email for the incremental run.

Is it possible to specify "no email" from the command line when I schedule my incremental run? From what I've read there is no way to do this at the moment.

mail policy will be available in the next release and there you will be able to specify the policy on the command line too.

--kkg

kulkarni_mangesh
April 21st, 2009, 02:20 AM
I have a further question on this thread.

I am now using a single configuration for both my daily and incremental (every 15 minutes) backups. I would like the daily run to send me an email, whereas I don't want an email for the incremental run.

Is it possible to specify "no email" from the command line when I schedule my incremental run? From what I've read there is no way to do this at the moment.

We can use post backup plugin for the same. ZRM passes arguments such as “--databases --backup-directory --checksum-pending “ to post backup plugin.
In “--backup-directory” you can find “index” file, in which search for “backup-level”, if it is set to “0” then it is full backup. You can write a script to read this value and send a mail by using mail command if backup-level is “0”.
If this works, disable automatic mailing for backup set.

For more info on post-backup-plugin read “/usr/share/mysql-zrm/plugins/post-backup.pl”.

linuxguy
April 21st, 2009, 10:52 AM
I didn't mean to hijack this thread but, when backups are configured via mysql user cron, how do you tell it not to mail 'root' account every time it runs a job. Sendmail is not configured for mysql user - is there a way to add mysql user to sendmail to avoid this or stop this email process all together>?

kulkarni_mangesh
April 21st, 2009, 08:19 PM
I didn't mean to hijack this thread but, when backups are configured via mysql user cron, how do you tell it not to mail 'root' account every time it runs a job. Sendmail is not configured for mysql user - is there a way to add mysql user to sendmail to avoid this or stop this email process all together>?

Can you check "mailto" option in /etc/mysql-zrm/__backup_set_name__/mysql-zrm.conf OR /etc/mysql-zrm/mysql-zrm.conf
files, this might have been set to mailto="root@localhost".

linuxguy
April 22nd, 2009, 12:18 PM
Can you check "mailto" option in /etc/mysql-zrm/__backup_set_name__/mysql-zrm.conf OR /etc/mysql-zrm/mysql-zrm.conf
files, this might have been set to mailto="root@localhost".

I checked and its not.

kulkarni_mangesh
April 24th, 2009, 01:02 AM
I checked and its not.

What is the subject of the mail, which are coming in Inbox of “root” user…? This might be sent from CRON daemon, stating that, cron has been executed for the user “mysql”.

Can you please post content of the mail along with the header…?