PDA

View Full Version : amcheck failure on Tape Server, local client.



steves
August 3rd, 2006, 10:30 AM
I'm sure this is something simple I have missed but I have read the troubleshooting tips and checked the log files. This is on a 2.5.0p2 upgrade from 2.4.5.
The error is:
WARNING: elpaso.here.com: selfcheck request failed: timeout waiting for REP.
This is netstat -a output:
tcp 0 0 *:amandaidx *:* LISTEN
udp 0 0 *:amanda *:*
*I didn't look at these under 2.4.5, is amanda also supposed to have "LISTEN"?
lsof:
xinetd 2102 root 5u IPv4 5571 UDP *:amanda
xinetd 2102 root 6u IPv4 5572 TCP *:amandaidx (LISTEN)

here is the amandad.x.log generated when running amcheck -c DailySet1
amandad: debug 1 pid 2916 ruid 33 euid 33: start at Thu Aug 3 12:42:01 2006
amandad: version 2.5.0p2
amandad: build: VERSION="Amanda-2.5.0p2"
amandad: BUILT_DATE="Thu Aug 3 08:52:38 CDT 2006"
amandad: BUILT_MACH="Linux elpaso.here.com 2.6.17-1.2142_FC4 #1 Tue Jul 11 22:41:14 EDT 2006 i686 athlon i386 GNU/Linux"
amandad: CC="gcc"
amandad: CONFIGURE_COMMAND="'./configure' '--build=i686-redhat-linux-gnu' '--host=i686-redhat-linux-gnu' '--target=i386-redhat-linux-gnu' '--program-prefix=' '--prefix=/usr' '--exec-prefix=/usr' '--bindir=/usr/bin' '--sbindir=/usr/sbin' '--sysconfdir=/etc' '--datadir=/usr/share' '--includedir=/usr/include' '--libdir=/usr/lib' '--libexecdir=/usr/lib/amanda' '--localstatedir=/var/lib' '--sharedstatedir=/usr/com' '--mandir=/usr/share/man' '--infodir=/usr/share/info' '--enable-shared' '--disable-dependency-tracking' '--with-index-server=localhost' '--with-tape-server=localhost' '--with-config=DailySet1' '--with-gnutar-listdir=/var/lib/amanda/gnutar-lists' '--with-smbclient=/usr/bin/smbclient' '--with-amandahosts' '--with-user=amanda' '--with-group=disk' '--with-tmpdir=/var/log/amanda' '--with-gnutar=/bin/tar'"
amandad: paths: bindir="/usr/bin" sbindir="/usr/sbin"
amandad: libexecdir="/usr/lib/amanda" mandir="/usr/share/man"
amandad: AMANDA_TMPDIR="/var/log/amanda"
amandad: AMANDA_DBGDIR="/var/log/amanda" CONFIG_DIR="/etc/amanda"
amandad: DEV_PREFIX="/dev/" RDEV_PREFIX="/dev/" DUMP="/sbin/dump"
amandad: RESTORE="/sbin/restore" VDUMP=UNDEF VRESTORE=UNDEF
amandad: XFSDUMP=UNDEF XFSRESTORE=UNDEF VXDUMP=UNDEF VXRESTORE=UNDEF
amandad: SAMBA_CLIENT="/usr/bin/smbclient" GNUTAR="/bin/tar"
amandad: COMPRESS_PATH="/bin/gzip" UNCOMPRESS_PATH="/bin/gzip"
amandad: LPRCMD="/usr/bin/lpr" MAILER="/usr/bin/Mail"
amandad: listed_incr_dir="/var/lib/amanda/gnutar-lists"
amandad: defs: DEFAULT_SERVER="localhost" DEFAULT_CONFIG="DailySet1"
amandad: DEFAULT_TAPE_SERVER="localhost"
amandad: DEFAULT_TAPE_DEVICE="null:" HAVE_MMAP HAVE_SYSVSHM
amandad: LOCKING=POSIX_FCNTL SETPGRP_VOID DEBUG_CODE
amandad: AMANDA_DEBUG_DAYS=4 BSD_SECURITY RSH_SECURITY USE_AMANDAHOSTS
amandad: CLIENT_LOGIN="amanda" FORCE_USERID HAVE_GZIP
amandad: COMPRESS_SUFFIX=".gz" COMPRESS_FAST_OPT="--fast"
amandad: COMPRESS_BEST_OPT="--best" UNCOMPRESS_OPT="-dc"
amandad: time 29.998: pid 2916 finish time Thu Aug 3 12:42:31 2006

Please show me the error of my ways on this. Thank you.

-Steve

paddy
August 3rd, 2006, 11:15 AM
Can you provide information from .amandahosts on the Amanda client?

Do you have any messages in /tmp/amanda/selfcheck*?

It appears the selfcheck request was not received by amandad

Paddy.

steves
August 3rd, 2006, 11:47 AM
Hi Paddy,
Thanks for your prompt reply!

This is something that happened on the upgrade from 2.4.5 -> 2.5.0p2.

The server "elpaso" is attempting to contact the local client of "elpaso". The remote clients of "baytown" & "jrlinux", do not complain. They still have 2.4.5 clients installed.

Here is the information you requested.

.amandahosts
elpaso.here.com amanda
elpaso.here.com root
baytown root
jrlinux root

The directory "/tmp/amanda" is empty.

I also just added a copy of another client's amanda-client.conf file to "/etc/amanda" & "/var/lib/amanda". That didn't seem to help.

-Steve

steves
August 3rd, 2006, 12:52 PM
OK, I'm having other problems too. I am changing to your provided rpms.
amanda-backup_server-2.5.0p2-1.fc4.i386.rpm. Hopefully, that will get me going again. I'll post the outcome. Thank you, again!

Steve

steves
August 4th, 2006, 10:57 AM
I have upgraded to 2.5.0p2 from your RPMs. I have changed over the user from amanda to amandabackup but I am still having the same problem trying to talk to the client on the same machine as the server.
The 1st error I saw was:
WARNING: elpaso: selfcheck request failed: timeout waiting for ACK

(Ah yes, I saw this error in the troubleshooting tips!)
I fixed that by changing the xinetd configuration user for amanda, amandaidx & amidxtape from amanda to amandabackup.

Restarted xinetd and get this error:
WARNING: elpaso: selfcheck request failed: timeout waiting for REP
My iptables are down...
# iptables -L
Chain FORWARD (policy ACCEPT)
target prot opt source destination

Chain INPUT (policy ACCEPT)
target prot opt source destination

Chain OUTPUT (policy ACCEPT)
target prot opt source destination

running amcheck to another linux client (2.5.0.p2), works fine.

paddy
August 4th, 2006, 11:02 AM
I'm trying to understand your problem.

Are you having issues when localhost is being used as Amanda client as well as
server? If you use different client, amcheck works. Is my understanding correct?

What authentication protocol are you using?

Any information /tmp/amanda/amandad* or /tmp/amanda/selfcheck* logs on the
machine acting as amanda server as well as amanda client?
Thanks,
Paddy

steves
August 4th, 2006, 11:44 AM
I'm trying to understand your problem.

Are you having issues when localhost is being used as Amanda client as well as
server? If you use different client, amcheck works. Is my understanding correct?

Yes that is correct. Client & server are on same box. Other client(not same box) works.

What authentication protocol are you using?
default BSD
Any information /tmp/amanda/amandad*

here is most of this file:
amandad: debug 1 pid 13318 ruid 511 euid 511: start at Fri Aug 4 13:57:30 2006
amandad: version 2.5.0p2
amandad: build: VERSION="Amanda-2.5.0p2"
amandad: BUILT_DATE="Fri May 12 12:40:52 PDT 2006"
[snip]
more build info
[snip]
amandad: time 0.002: accept recv REQ pkt:
<<<<<
SERVICE noop
OPTIONS features=fffffeff9ffeffff07;
>>>>>
amandad: time 0.004: creating new service: /usr/lib/amanda/noop
OPTIONS features=fffffeff9ffeffff07;
amandad: time 0.009: sending ACK pkt:
<<<<<
>>>>>
amandad: time 0.009: accept recv REQ pkt:
<<<<<
SERVICE noop
OPTIONS features=fffffeff9ffeffff07;
>>>>>
amandad: time 0.009: /usr/lib/amanda/noop OPTIONS features=fffffeff9ffeffff07;
: already running, acking req
amandad: time 0.009: sending ACK pkt:
<<<<<
>>>>>
amandad: time 30.012: pid 13318 finish time Fri Aug 4 13:58:00 2006

or /tmp/amanda/selfcheck* logs on the
machine acting as amanda server as well as amanda client?

If you mean amcheck, here it is:
amcheck: debug 1 pid 13305 ruid 511 euid 0: start at Fri Aug 4 13:56:10 2006
amcheck-clients: time 0.002: bind_portrange2: trying port=580
amcheck-clients: time 0.002: dgram_bind: socket bound to 0.0.0.0.580
amcheck: pid 13305 finish time Fri Aug 4 13:58:00 2006

Thanks,
Paddy
Thank you,
Steve

steves
August 7th, 2006, 06:13 AM
Ok amcheck passes now. All I needed was to step back and try a fresh troubleshooting approach! This failure:

WARNING: elpaso.here.com: selfcheck request failed: timeout waiting for REP

was caused by the fully qualified hostname. Even though running hostname returns elpaso.here.com. After I removed the domain, it passed the check. The prevous version gave a warning about not using the fully qualified host name.

Is not using the fully qualified hostname by desgn in version 2.5.0p2 ?

I'm sure I'll have other questions in the future. Thanks for the help, Paddy.

-Steve