PDA

View Full Version : amanda error timeout waiting for ACK



romaha
July 31st, 2006, 11:58 PM
Hi,
I have setup amanda server and amanda client on FreeBsd 6.0 and made DailySet1 configuration on server. So when I.m running amcheck amcheck DailySet1 on server side - I receive error :
WARNING: 10.21.15.21: selfcheck request failed: timeout waiting for ACK
Client check: 1 host checked in 30.011 seconds, 1 problem found

10.21.15.21 - is my amanda client.
I dont know if I have to configure amanda-client.conf and how to start amanda client amandad. I have started it In inetd.conf and inetd listens tcp: 10082 10083 and udp 10080.

paddy
August 1st, 2006, 08:08 AM
Hi Romaha,

Which version of Amanda are you using? If you are using 2.5.1b1 or
2.5.1b2, you should set up amanda-client.conf on the Amanda client.
For information on amanda-client.conf, see http://wiki.zmanda.com/index.php/Amanda-client.conf

For information on amcheck error - "timeout waiting for ACK", see
http://wiki.zmanda.com/index.php/Amcheck:_selfcheck_request_failed

In your case, it appears that Amanda client may not be correctly configured.

amandad is started by inetd. xinetd configuration for 2.5.1b1 and 2.5.1b2 is
documented in http://wiki.zmanda.com/index.php/Configuring_bsd/bsdudp/bsdtcp_authentication

Paddy

romaha
August 2nd, 2006, 12:29 AM
I am using Amanda 2.5.0p2
I configured amanda-client.conf:
#begin file

#conf
index_server 10.21.15.21
tape_server 10.21.15.21
tapedev null
auth bsd
#ssh_keys string
gnutar_list_dir /usr/local/var/amanda/gnutar-lists
amandates /etc/amandates

#end file

and here are amanda strings from inetd.conf

amanda dgram udp wait operator /usr/local/libexec/amanda/amandad amandad
amandaidx stream tcp nowait operator /usr/local/libexec/amanda/amindexd amindexd
amidxtape stream tcp nowait operator /usr/local/libexec/amanda/amidxtaped amidxtaped


So, I have the same error. I think inetd cannot start amandad on client side.
Maybe amanda-client.config is wrong?

ktill
August 2nd, 2006, 08:27 AM
* restart inetd and check to see if there is any error message in the syslog.

* start /usr/local/libexec/amanda/amandad manually to see if there is any error. If not, it should exit in a minute or so.

* what is in the disklist file?

paddy
August 2nd, 2006, 09:28 AM
Hi Romaha,

If you are using 2.5.0p2, the amanda-client.conf is not relevant. Only
2.5.1 versions use amanda-client.conf.

Please provide the information that Kevin has asked for.

Take a look at checklist in http://wiki.zmanda.com/index.php/Argh%21_It_still_won%27t_work%21_I_have_a_%22host_ down%22_error_and_can%27t_figure_out_why%21

Is "operator" a valid user for the amanda client?

Is the location for amandad binary correct? If you are using source rpms from
Zmanda website, the location will be /usr/lib/amanda/amandad

Paddy

romaha
August 3rd, 2006, 10:13 PM
Hi Paddy!
You was right, the problem was in inetd daemon. On client side it was running without parameters. Now I start it with parameters:
/usr/sbin/inetd -wW -C 60
Now all scripts are runnig properly.

Thank you for your help!

paddy
August 4th, 2006, 08:36 AM
Hi Romaha,

Did you change anything else (besides adding -wW -C 60 options to inetd)?

I think -wW enables tcp wrappers. I think 60 simultaneous connections
would not make a difference.

I'm just curious which change made Amanda work. If possible, it will
be great if you can update http://wiki.zmanda.com with the information.

Thanks,
Paddy

romaha
August 7th, 2006, 12:05 AM
Hi Paddy,
I think that amanda-client was configured right, but all problems was that inetd couldn't start properly, maybe I had to reboot machine, because I changed nothing
when I made

root# ps ax | grep inedt
I have : /usr/sbin/inetd -wW -C 60

when amchek didn't work
I had : /usr/sbin/inetd

And I could'n connect to its port. I think problem was in inetd daemon

romaha
August 7th, 2006, 05:58 AM
Hi Paddy!
I know what problem was.
My amanda client and server were compilen with fqdn option. And clent didn't resolve a server hostname. When I add name records into /etc/hosts - amcheck workk, without this it doesn't.

paddy
August 7th, 2006, 09:18 AM
Hi Romaha,

Thanks for your reply. I have updated the Amanda wiki - http://wiki.zmanda.com/

Paddy

romaha
August 8th, 2006, 06:37 AM
Hi Paddy,
When amanda-server host and amanda client-host are at the same lan
(for ex. in 192.168.1.0/24 ) - amchek and amdump are working properly.
But when amanda-client is from another lan (192.168.2.0) I cannot make amcheck and amdump).
All network and route settings are configured properly.

Has amanda some network limitations?

paddy
August 8th, 2006, 11:00 AM
Amanda server and client can be in different physical network.

Do you have any router or firewall between the networks? Can you do pings
between the networks using FQDN? Please make sure you have used
FQDN in amanda configs.

Paddy

romaha
August 13th, 2006, 11:37 PM
Hi,
The mistakes were with the resolvings hosts and with firewalling.
Also on client side folder /usr/local/var/amanda/gnutar-lists was missed
(when I install amanda from ports - folder is created by default, but when I install from tar.gz - I have to create this folder by hand).

AdrianChallinor
May 22nd, 2008, 10:28 AM
A little late to this party, but I had the same problem. Mine was fixed when I put in both the FQDN and host name in to the .amandahosts file. It had been working fine with just the FQDN, but I think an update caught me out. This fixed it.