PDA

View Full Version : Installation error: Failed dependencies:



aankdavid
April 21st, 2008, 08:02 PM
before I try to Install ZRM for MySQL, I have complete install

DBI-1.604 :
perl Makefile.PL
make
make test
make install
and XML-Parser-2.36 :
perl Makefile.PL
make
make test
make install

but i got error :
root@myhost:/# rpm -ivh MySQL-zrm-2.0-1.noarch.rpm
warning: MySQL-zrm-2.0-1.noarch.rpm: V3 DSA signature: NOKEY, key ID 3c5d1c92
error: Failed dependencies:
/bin/sh is needed by MySQL-zrm-2.0-1
/usr/bin/perl is needed by MySQL-zrm-2.0-1
mailx is needed by MySQL-zrm-2.0-1
perl is needed by MySQL-zrm-2.0-1
perl(Carp) is needed by MySQL-zrm-2.0-1
perl(Exporter) is needed by MySQL-zrm-2.0-1
perl(Fcntl) is needed by MySQL-zrm-2.0-1
perl(File::Basename) is needed by MySQL-zrm-2.0-1
perl(File::Copy) is needed by MySQL-zrm-2.0-1
perl(File::Find) is needed by MySQL-zrm-2.0-1
perl(File::Path) is needed by MySQL-zrm-2.0-1
perl(File::Spec::Functions) is needed by MySQL-zrm-2.0-1
perl(File::Temp) is needed by MySQL-zrm-2.0-1
perl(Getopt::Long) is needed by MySQL-zrm-2.0-1
perl(POSIX) is needed by MySQL-zrm-2.0-1
perl(Socket) is needed by MySQL-zrm-2.0-1
perl(Time::Local) is needed by MySQL-zrm-2.0-1
perl(XML::Parser) is needed by MySQL-zrm-2.0-1
perl(base) is needed by MySQL-zrm-2.0-1
perl(lib) is needed by MySQL-zrm-2.0-1
perl(strict) is needed by MySQL-zrm-2.0-1
perl(vars) is needed by MySQL-zrm-2.0-1
perl(warnings) is needed by MySQL-zrm-2.0-1
perl-DBI is needed by MySQL-zrm-2.0-1


please help me to Install ZRM for MySQL...

Thanks

kkg
April 21st, 2008, 08:14 PM
before I try to Install ZRM for MySQL, I have complete install

DBI-1.604 :
perl Makefile.PL
make
make test
make install
and XML-Parser-2.36 :
perl Makefile.PL
make
make test
make install

but i got error :
root@myhost:/# rpm -ivh MySQL-zrm-2.0-1.noarch.rpm
warning: MySQL-zrm-2.0-1.noarch.rpm: V3 DSA signature: NOKEY, key ID 3c5d1c92
error: Failed dependencies:
/bin/sh is needed by MySQL-zrm-2.0-1
/usr/bin/perl is needed by MySQL-zrm-2.0-1
mailx is needed by MySQL-zrm-2.0-1
perl is needed by MySQL-zrm-2.0-1
perl(Carp) is needed by MySQL-zrm-2.0-1
perl(Exporter) is needed by MySQL-zrm-2.0-1
perl(Fcntl) is needed by MySQL-zrm-2.0-1
perl(File::Basename) is needed by MySQL-zrm-2.0-1
perl(File::Copy) is needed by MySQL-zrm-2.0-1
perl(File::Find) is needed by MySQL-zrm-2.0-1
perl(File::Path) is needed by MySQL-zrm-2.0-1
perl(File::Spec::Functions) is needed by MySQL-zrm-2.0-1
perl(File::Temp) is needed by MySQL-zrm-2.0-1
perl(Getopt::Long) is needed by MySQL-zrm-2.0-1
perl(POSIX) is needed by MySQL-zrm-2.0-1
perl(Socket) is needed by MySQL-zrm-2.0-1
perl(Time::Local) is needed by MySQL-zrm-2.0-1
perl(XML::Parser) is needed by MySQL-zrm-2.0-1
perl(base) is needed by MySQL-zrm-2.0-1
perl(lib) is needed by MySQL-zrm-2.0-1
perl(strict) is needed by MySQL-zrm-2.0-1
perl(vars) is needed by MySQL-zrm-2.0-1
perl(warnings) is needed by MySQL-zrm-2.0-1
perl-DBI is needed by MySQL-zrm-2.0-1


please help me to Install ZRM for MySQL...

Thanks

If you are sure you have installed all of the required dependencies from source, then use the --nodeps when installing.

--kkg

dustin
April 21st, 2008, 08:25 PM
Agreed -- this looks like a broken rpm database of some sort. Certainly /bin/sh is installed!

aankdavid
April 21st, 2008, 09:20 PM
I try to make test :
-DBI and perl-XML-parser/DBI-1.604# make test
PERL_DL_NONLAZY=1 /usr/bin/perl5.8.8 "-MExtUtils::Command::MM" "-e" "test_harness(0, 'blib/lib', 'blib/arch')" t/*.t
t/01basics................ok
4/130 skipped: developer tests
t/02dbidrv................ok
t/03handle................ok
t/04mods..................ok
t/05thrclone..............skipped
all skipped: this linux perl 5.008008 not supported for DBI iThreads
t/06attrs.................ok
t/07kids..................ok
t/08keeperr...............ok
t/09trace.................ok
t/10examp.................ok
t/11fetch.................ok
t/12quote.................ok
t/13taint.................ok
t/14utf8..................ok
t/15array.................ok
t/19fhtrace...............ok
t/20meta..................ok
t/30subclass..............ok
t/40profile...............ok
t/41prof_dump.............ok
1/15 skipped: developer-only test
t/42prof_data.............ok
t/43prof_env..............ok
t/50dbm...................ok
t/60preparse..............ok
t/65transact..............ok
t/70callbacks.............ok
t/72childhandles..........ok
t/80proxy.................skipped
all skipped: modules required for proxy are probably not installed (e.g., RPC/PlClient.pm)
t/85gofer.................ok
18/234 skipped: caching of metadata methods returning sth not yet implemented
t/86gofer_fail............ok
t/87gofer_cache...........ok
t/pod-coverage............skipped
all skipped: Test::Pod::Coverage 1.04 required for testing POD coverage
t/pod.....................skipped
all skipped: Test::Pod 1.00 required for testing POD
t/zvg_01basics............ok
4/130 skipped: developer tests
t/zvg_02dbidrv............ok
t/zvg_03handle............ok
44/137 skipped: various reasons
t/zvg_04mods..............ok
t/zvg_05thrclone..........skipped
all skipped: this linux perl 5.008008 not supported for DBI iThreads
t/zvg_06attrs.............ok
2/145 skipped: drh->dbh->sth inheritance test skipped with DBI_AUTOPROXY
t/zvg_07kids..............ok
t/zvg_08keeperr...........ok
t/zvg_09trace.............ok
t/zvg_10examp.............ok
t/zvg_11fetch.............ok
t/zvg_12quote.............ok
1/10 skipped: Can't test alternate quote_identifier logic with DBI_AUTOPROXY
t/zvg_13taint.............skipped
all skipped: Taint attribute tests not functional with DBI_AUTOPROXY
t/zvg_14utf8..............ok
t/zvg_15array.............ok
t/zvg_19fhtrace...........ok
t/zvg_20meta..............ok
t/zvg_30subclass..........ok
t/zvg_40profile...........ok
t/zvg_41prof_dump.........ok
1/15 skipped: developer-only test
t/zvg_42prof_data.........ok
t/zvg_43prof_env..........ok
t/zvg_50dbm...............ok
2/12 skipped: Can't set attributes after connect using DBD::Gofer
t/zvg_60preparse..........ok
t/zvg_65transact..........skipped
all skipped: Transactions not supported by DBD::Gofer
t/zvg_70callbacks.........ok
t/zvg_72childhandles......ok
2/14 skipped: slow tests avoided when using DBD::Gofer
t/zvg_80proxy.............skipped
all skipped: modules required for proxy are probably not installed (e.g., RPC/PlClient.pm)
t/zvg_85gofer.............ok
45/234 skipped: various reasons
t/zvg_86gofer_fail........skipped
all skipped: Gofer DBI_AUTOPROXY
t/zvg_87gofer_cache.......skipped
all skipped: Gofer DBI_AUTOPROXY
t/zvp_01basics............ok
6/130 skipped: various reasons
t/zvp_02dbidrv............ok
10/51 skipped: various reasons
t/zvp_03handle............ok
57/137 skipped: various reasons
t/zvp_04mods..............ok
t/zvp_05thrclone..........skipped
all skipped: this linux perl 5.008008 not supported for DBI iThreads
t/zvp_06attrs.............ok
7/145 skipped: various reasons
t/zvp_07kids..............skipped
all skipped: $h->{Kids} attribute not supported for DBI::PurePerl
t/zvp_08keeperr...........ok
t/zvp_09trace.............ok
t/zvp_10examp.............ok
3/208 skipped: inner/outer handles not fully supported for DBI::PurePerl
t/zvp_11fetch.............ok
t/zvp_12quote.............ok
t/zvp_13taint.............skipped
all skipped: Taint attributes not supported with DBI::PurePerl
t/zvp_14utf8..............ok
t/zvp_15array.............ok
t/zvp_19fhtrace...........ok
t/zvp_20meta..............ok
t/zvp_30subclass..........ok
t/zvp_40profile...........skipped
all skipped: profiling not supported for DBI::PurePerl
t/zvp_41prof_dump.........skipped
all skipped: profiling not supported for DBI::PurePerl
t/zvp_42prof_data.........skipped
all skipped: profiling not supported for DBI::PurePerl
t/zvp_43prof_env..........skipped
all skipped: profiling not supported for DBI::PurePerl
t/zvp_50dbm...............ok
t/zvp_60preparse..........skipped
all skipped: preparse not supported for DBI::PurePerl
t/zvp_65transact..........ok
t/zvp_70callbacks.........skipped
all skipped: $h->{Callbacks} attribute not supported for DBI::PurePerl
t/zvp_72childhandles......ok
t/zvp_80proxy.............skipped
all skipped: modules required for proxy are probably not installed (e.g., RPC/PlClient.pm)
t/zvp_85gofer.............ok
18/234 skipped: caching of metadata methods returning sth not yet implemented
t/zvp_86gofer_fail........skipped
all skipped: requires Callbacks which are not supported with PurePerl
t/zvp_87gofer_cache.......ok
t/zvxgp_01basics..........ok
6/130 skipped: various reasons
t/zvxgp_02dbidrv..........ok
10/51 skipped: various reasons
t/zvxgp_03handle..........ok
76/137 skipped: various reasons
t/zvxgp_04mods............ok
t/zvxgp_05thrclone........skipped
all skipped: this linux perl 5.008008 not supported for DBI iThreads
t/zvxgp_06attrs...........ok
9/145 skipped: various reasons
t/zvxgp_07kids............skipped
all skipped: $h->{Kids} attribute not supported for DBI::PurePerl
t/zvxgp_08keeperr.........ok
t/zvxgp_09trace...........ok
t/zvxgp_10examp...........ok
3/208 skipped: inner/outer handles not fully supported for DBI::PurePerl
t/zvxgp_11fetch...........ok
t/zvxgp_12quote...........ok
1/10 skipped: Can't test alternate quote_identifier logic with DBI_AUTOPROXY
t/zvxgp_13taint...........skipped
all skipped: Taint attributes not supported with DBI::PurePerl
t/zvxgp_14utf8............ok
t/zvxgp_15array...........ok
t/zvxgp_19fhtrace.........ok
t/zvxgp_20meta............ok
t/zvxgp_30subclass........ok
t/zvxgp_40profile.........skipped
all skipped: profiling not supported for DBI::PurePerl
t/zvxgp_41prof_dump.......skipped
all skipped: profiling not supported for DBI::PurePerl
t/zvxgp_42prof_data.......skipped
all skipped: profiling not supported for DBI::PurePerl
t/zvxgp_43prof_env........skipped
all skipped: profiling not supported for DBI::PurePerl
t/zvxgp_50dbm.............ok
2/12 skipped: Can't set attributes after connect using DBD::Gofer
t/zvxgp_60preparse........skipped
all skipped: preparse not supported for DBI::PurePerl
t/zvxgp_65transact........skipped
all skipped: Transactions not supported by DBD::Gofer
t/zvxgp_70callbacks.......skipped
all skipped: $h->{Callbacks} attribute not supported for DBI::PurePerl
t/zvxgp_72childhandles....ok
2/14 skipped: slow tests avoided when using DBD::Gofer
t/zvxgp_80proxy...........skipped
all skipped: modules required for proxy are probably not installed (e.g., RPC/PlClient.pm)
t/zvxgp_85gofer...........ok
45/234 skipped: various reasons
t/zvxgp_86gofer_fail......skipped
all skipped: requires Callbacks which are not supported with PurePerl
t/zvxgp_87gofer_cache.....skipped
all skipped: Gofer DBI_AUTOPROXY
All tests successful, 34 tests and 379 subtests skipped.
Files=126, Tests=5629, 258 wallclock secs (232.28 cusr + 14.93 csys = 247.21 CPU)
PERL_DL_NONLAZY=1 /usr/bin/perl5.8.8 "-Iblib/lib" "-Iblib/arch" test.pl
test.pl
DBI test application $Revision: 9451 $
Switch: DBI 1.604 by Tim Bunce, 1.604
Available Drivers: DBM, ExampleP, File, Gofer, Proxy, Sponge, mysql
dbi:ExampleP:: testing 3 sets of 20 connections:
Connecting... 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20
Disconnecting...
Connecting... 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20
Disconnecting...
Connecting... 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20
Disconnecting...
connect 20 and disconnect them, 3 times: 0.0330s / 60 = 0.0005s
Testing handle creation speed...
6006 NullP sth/s perl 5.008008 i486-linux (gcc 3.4.6 -O2 -march=i486 -mtune=i686) 0.000167s

test.pl done

aankdavid
April 22nd, 2008, 02:11 AM
/var/log/mysql-zrm/mysql-zrm.log :

Tue Apr 22 12:58:20 2008: dailyrun:backup:ERROR: Output of command: 'mysqlhotcopy'
is {
install_driver(mysql) failed: Can't load '/usr/lib/perl5/site_perl/5.8.8/i486-linu
x/auto/DBD/mysql/mysql.so' for module DBD::mysql: libmysqlclient.so.15: cannot ope
n shared object file: No such file or directory at /usr/lib/perl5/5.8.8/i486-linux
/DynaLoader.pm line 230.
at (eval 7) line 3
Compilation failed in require at (eval 7) line 3.
Perhaps a required shared library or dll isn't installed where expected
at /usr/bin/mysqlhotcopy line 178
}
Tue Apr 22 12:58:20 2008: dailyrun:backup:ERROR: mysqlhotcopy did not succeed. Com
mand used is mysqlhotcopy --user="root" --password="*****" --host="localhost" --po
rt="3306" --socket="/var/run/mysql/mysql.sock" --quiet dotproject "/data/david/b
ackup/dailyrun/dailyrun/20080422125819" > /tmp/579uxjJi0f 2>&1 Return value is 512
Tue Apr 22 12:58:20 2008: dailyrun:backup:INFO: PHASE START: Cleanup
Tue Apr 22 12:58:20 2008: dailyrun:backup:INFO: backup-status=Backup failed

How to solve this error message?
Thanks.