View Full Version : Restore problem Win client 2.5.1p1 - "Permission denied"

February 22nd, 2008, 12:31 PM
Hi all!!

I'm using Cygwin client 2.5.1p1 - from Zmanda wiki - to backup some WinXP hosts. I've managed to install the client succesfully, by renaming some accounts and groups - it's a brazilian installation... I've decided to use 2.5.1p1 client so that it match the version on our Debian Etch backup server.

So, backup runs just fine! Dumps are written succesfully - I checked, everything there. The problem occurs on restore. I tried 'amrecover' - from the recovery shell provided -, selected a disk and directory succesfully, but when tried 'extract', the program dumped a lot of "Permission denied" messages, on EVERY file that it tried to extract. The directory tree was rebuilt, though.

I assume everything went fine with the proccess, and that I have some user/group permission problem when restoring. I was able to recover the files in question by stopping the proccess some times - actually, every tme it finished processing directories, 'cause looked like 'amrestore' rebuild directory tree before recovering the files - and resetting permissions on the directory tree, making it readable/writeable by the 'Everyone' group.

So, has anyone some idea? I've read the documentation on Cygwin website about their mapping between Win/Unix security, which appear to be the problem, and it's possible to make the two run together, but it's a lot of effort - it involves some hacking in the passwd and groups files on *each* client, so that it reflects the groups and users on site.

Last, I would say the machines are part of a domain, Samba controlled - working well. Hope this help describe the basics of the environment.


P.S.: forgive any mistakes on the english; as you may have noticed, I'm brazilian. :-)

February 25th, 2008, 01:23 PM
So, should I consider this a dead end? :-(

July 22nd, 2009, 01:44 PM

Did You resolve your problem?

Rodolfo Barbosa
Ps.: I'm sorry about the English post.