Results 1 to 5 of 5

Thread: Remote Host Connection (Centos)

  1. #1

    Default Remote Host Connection (Centos)

    Hi all,

    I'm testing Amanda backup on Centos 4.4.
    For now, Backup and restore are working well locally, but I'm not able to get remote connection!

    Server side:

    .amandahosts

    localhost amandabackup amdump
    localhost.localdomain amandabackup amdump
    localhost root amindexd amidxtaped
    localhost.localdomain root amindexd amidxtaped
    bck02 amandabackup amdump
    bck02.e-adresse.be amandabackup amdump
    bck02 root amindexd amidxtaped
    bck02.e-adresse.be root amindexd amidxtaped
    host1.e-address.be amandabackup


    amanda.conf

    org "LADAM"
    mailto "you@example.com"
    dumpcycle 7
    runspercycle 5
    tapecycle 5
    dumpuser "amandabackup"
    tpchanger "chg-disk" # a virtual tape changer
    tapedev "file:/space/vtapes/test/slots"
    changerfile "/var/lib/amanda/test/changerfile"
    labelstr "TEST-.*"
    #label_new_tapes "TEST-%%"
    tapetype DVD_SIZED_DISK
    logdir "/var/lib/amanda/test"
    infofile "/var/lib/amanda/test/curinfo"
    indexdir "/var/lib/amanda/test/index"
    tapelist "/var/lib/amanda/test/tapelist"

    holdingdisk hd1 {
    directory "/space/amandahold/test"
    }

    define dumptype comp-tar {
    program "GNUTAR"
    compress fast
    index yes
    record no # Important! avoid interfering with production runs
    }

    define tapetype DVD_SIZED_DISK {
    filemark 4 KB
    length 4482 MB
    }


    xinet.d/amanda

    service amanda
    {
    only_from = bck02.e-address.be
    socket_type = dgram
    protocol = udp
    wait = yes
    user = amandabackup
    group = disk
    groups = yes
    server = /usr/lib/amanda/amandad
    server_args = -auth=bsd amdump amindexd amidxtaped
    disable = no
    }


    On client side

    xinetd.d/amanda

    service amanda
    {
    only_from = bck02.e-address.be
    socket_type = dgram
    protocol = udp
    wait = yes
    user = amandabackup
    group = disk
    groups = yes
    server = /usr/lib/amanda/amandad
    server_args = -auth=bsd amdump
    disable = no
    }

    .amandahosts

    bck02.e-address.be amandabackup


    amcheck test result :

    -sh-3.00$ amcheck test
    Amanda Tape Server Host Check
    -----------------------------
    Holding disk /space/amandahold/test: 2552036 kB disk space available, using 2552036 kB
    slot 5: read label `TEST-5', date `X'
    NOTE: skipping tape-writable test
    Tape TEST-5 label ok
    WARNING: tapecycle (5) <= runspercycle (5).
    NOTE: host info dir /var/lib/amanda/test/curinfo/webmail.adam-family.be does not exist
    NOTE: it will be created on the next run.
    NOTE: index dir /var/lib/amanda/test/index/webmail.adam-family.be does not exist
    NOTE: it will be created on the next run.
    Server check took 0.676 seconds

    Amanda Backup Client Hosts Check
    --------------------------------
    WARNING: webmail.adam-family.be: selfcheck request failed: timeout waiting for ACK
    Client check: 2 hosts checked in 30.383 seconds, 1 problem found

    (brought to you by Amanda 2.5.1p3)



    My guest is that is auth problem! But...
    Do I have to use ssh auth? If yes how?

    I installed :

    amanda-backup_client-2.5.1p3-1.rhel4.i386.rpm
    amanda-backup_server-2.5.1p3-1.rhel4.i386.rpm

    Thanks
    to all

  2. #2

    Default

    Check if only_from field in the xinetd configuration on server and client is correct.
    You have the same value on both places and I think client name is webmail.adam-family.be

    Paddy

  3. #3

    Default Remote Connection

    Thanks.

    But I think it's normal as only the Amanda backup server should be referenced there. To be sure, I have added client name, but problem is still present.

  4. #4

    Default Remote Connection resolved

    Please close ticket.

    Problem was due to the fact that my FW acts also as internal router and was doing NAT bewteen internal LANs.

    Thanks

    LAD

  5. #5

    Default

    Thanks for your update.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •