Results 1 to 10 of 10

Thread: amrecover - can't talk to tape server: service amidxtaped: Help please.

  1. #1

    Default amrecover - can't talk to tape server: service amidxtaped: Help please.

    Hellow, im new at using AMANDA, and i need it for my last grade work.

    When i try to recover AMANDA, i can check al the files y have in the backups, but i cant extract them.

    This is the message that i receive when i try to do it.


    Extracting files using tape drive changer on host localhost.
    Load tape MyData03 now
    Continue [?/Y/n/s/d]? extract
    Continue [?/Y/n/s/d]? d
    New device name [?]: changer
    Using tape "changer" from server localhost.
    Continue [?/Y/n/s/d]? y
    amrecover - can't talk to tape server: service amidxtaped:
    amrecover> exit
    200 Good bye.



    Im using this distribution
    : Ubuntu 12.04.1 LTS

    This is my amanda.conf file:

    org "MyConfig"
    infofile "/amanda/state/curinfo"
    logdir "/amanda/state/log"
    indexdir "/amanda/state/index"
    dumpuser "backup"

    tpchanger "chg-disk:/amanda/vtapes"
    labelstr "MyData[0-9][0-9]"
    autolabel "MyData%%" EMPTY VOLUME_ERROR
    tapecycle 4
    dumpcycle 3 days
    amrecover_changer "changer"

    tapetype "TEST-TAPE"
    define tapetype TEST-TAPE {
    length 100 mbytes
    filemark 4 kbytes
    }

    define dumptype simple-gnutar-local {
    auth "local"
    compress none
    program "GNUTAR"
    }

    define dumptype simple-gnutar-remote {
    auth "bsdtcp"
    compress none
    program "GNUTAR"
    }

    holdingdisk hd1 {
    directory "/amanda/holding"
    use 50 mbytes
    chunksize 1 mbyte
    }


    This is my disklist file:


    localhost /etc simple-gnutar-local
    UBUNTUcli-10.asir2t-10.centro /etc simple-gnutar-remote
    localhost //XP-10/Copias simple-gnutar-local


    This is my amandahosts file:

    localhost backup amdump
    UBUNTU-10.asir2t-10.centro backup amdump
    localhost root amindexd amidxtaped
    UBUNTU-10.asir2t-10.centro amindexd amidxtaped


    Please if there is anything you can say to help me i will really appreciate it.

    If there is any other file or data you need to know ask freely.

  2. #2
    Join Date
    Nov 2005
    Location
    Canada
    Posts
    1,049

    Default

    Which auth are you using? it default to bsdtcp, do you configured xinetd?

    If you want to use the 'local' auth then add it to amanda-client.conf or on the mrecover command line: -oauth=local

  3. #3

    Default

    I checked the xinetd, but i didnt see anything wrong, once im able to put the data i will put them here.

    Do you have to put an amanda-client.conf in every client?
    It must be always in this rute? /etc/amanda/amanda-client.conf:

    And does it have always have to have this info?

    index_server "localhost"
    tapedev "changer"
    auth "local"


    Or if you have to use a client that is not the server, you have to set UBUNTU-10.asir2t-10.centro (domain name)?

    EDIT---

    I checked everything, and i cant find what is wrong. Ill put other files i have. I changed some localhost to -> UBUNTU-10 , is that ok? or is completely wrong?

    /etc/xinetd.d/amanda :

    # default: on
    #
    # description: Amanda services for Amanda server and client.
    #

    service amanda
    {
    disable = no
    flags = IPv4
    socket_type = stream
    protocol = tcp
    wait = no
    user = backup
    group = disk
    groups = yes
    server = /usr/lib/amanda/amandad
    server_args = -auth=bsdtcp amdump amindexd amidxtaped
    }


    /etc/amanda/amanda-client.conf :

    index_server "UBUNTU-10"
    tapedev "changer"
    auth "local"[/I]

    /etc/amanda/MyConfig/disklist :

    UBUNTU-10 /etc simple-gnutar-local

    UBUNTUcli-10 /etc simple-gnutar-remote

    UBUNTU-10 //XP-10/Copias simple-gnutar-local



    /var/backups/.amandahosts :

    localhost backup amdump

    UBUNTU-10 backup amdump

    localhost root amindexd amidxtaped

    UBUNTU-10 root amindexd amidxtaped


    I think this is all the relevant files to my problem, what else can i do? what seems wrong?
    Last edited by Gonzalo Ruiz; May 9th, 2013 at 07:36 AM. Reason: More info

  4. #4

    Default

    I tried everything about the auth, but it doesnt seem to work, please, there is anything else that you can gibe me for advice?

  5. #5

    Default

    I tried everything about the auth, ant it is not working, there is any other help or advice that can you ibe me, please?

  6. #6
    Join Date
    Nov 2005
    Location
    Canada
    Posts
    1,049

    Default

    What's in /etc/amanda/amanda-client.conf on the amanda client? Is it set to bsdtcp?
    Do you restarted the xinetd daemon on the server?

  7. #7

    Default

    Im not sure how to start the xinetd daemon,

    This is what is en the /etc/amanda/amanda-client.conf

    index_server "UBUNTU-10"
    tapedev "changer"
    auth "local"

    Is it correct?

    Do i have to write more things on it?

  8. #8
    Join Date
    Nov 2005
    Location
    Canada
    Posts
    1,049

    Default

    Do the amanda server is the same machine as the amanda client? You can't use the local auth if they are not the same machine.

    The xinetd file must be on the amanda server, look in the distribution documentation to find how to restart it.

  9. #9

    Default

    I have 3 clients, one of them is the same machine, other one is a Windows wich i backup with samba, so i guess that also counts as a local one. The thing is that is that i tried both auth, bsdtcp and local, and i dont make it to work.

  10. #10
    Join Date
    Nov 2005
    Location
    Canada
    Posts
    1,049

    Default

    'local' auth should works if you run amrecover on the amanda server.

    I can't help you more since you don't post what you do exactly and the error you get.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •