Results 1 to 4 of 4

Thread: amrecover: 599 index file not found

  1. #1

    Default amrecover: 599 index file not found

    My setup -- 3.2.3
    server name: server1.sanfrera.com.
    client name: clt1.sanfrera.com. backup disk: /backup-data

    I ran "amdump DailySet1" successfully for a couple of times within last 2 weeks. Now I want to recover the backup data for /backup-data, but got error indicated in the title line. Here is process.
    As root on clit1.sanfrera.com:

    [root@clt1 ~]# amrecover -C DailySet1 -s server1 -t server1
    AMRECOVER Version 3.2.3. Contacting server on server1 ...
    220 server1 AMANDA index server (3.2.3) ready.
    Setting restore date to today (2011-07-07)
    200 Working date set to 2011-07-07.
    200 Config set to DailySet1.
    200 Dump host set to clt1.sanfrera.com.
    Use the setdisk command to choose dump disk to recover
    amrecover> listdisk
    200- List of disk for host clt1.sanfrera.com
    201- /backup-data
    200 List of disk for host clt1.sanfrera.com
    amrecover> setdisk /backup-data
    200 Disk set to /backup-data.
    599 index file not found

    When ran "ls" this is nothing available to recover. I can see on server1 that indexes did exist :

    -sh-3.2$ ls -l
    total 128
    -rw------- 1 amandabackup disk 40381 Jun 9 23:17 20110609231632_0
    -rw------- 1 amandabackup disk 686 Jun 15 22:20 20110615222008_1.gz
    -rw------- 1 amandabackup disk 686 Jul 6 13:36 20110706133616_1.gz
    -rw------- 1 amandabackup disk 686 Jul 6 13:46 20110706134609_1.gz
    -rw------- 1 amandabackup disk 45409 Jul 7 14:08 20110706144256_1
    -rw------- 1 amandabackup disk 4315 Jul 6 14:43 20110706144256_1.gz
    -sh-3.2$ pwd
    /etc/amanda/DailySet1/index/clt1.sanfrera.com/_backup-data

    Can anyone help me?

    TIA,
    Allen

  2. #2

    Default Figured out by myself

    The reason was the disk name I used was /backup-data, the hyphen "-" caused the problem. After I renamed it without "-", both backup and restore worked.
    Still need to know how to backup the data source with "-" in the name.

  3. #3
    Join Date
    Oct 2012
    Posts
    2

    Default

    I got the same problem, but I can't even restore a disk which has no "-" (hyphen) in it. let's I want to recover "/testbckfiles" I get "599 index file not found"! But the index files do exist! Can a configured disk which contains a "-" (hyphen) be responsible for that??? I am struggling with this for weeks now. Any hint is highly appreciated! Thanks a lot in advance!

    This is the output of amrecover:
    amanda:/tmp/recoverytest # amrecover dailybck
    AMRECOVER Version 3.3.0. Contacting server on localhost ...
    220 amanda AMANDA index server (3.3.0) ready.
    Setting restore date to today (2012-10-08)
    200 Working date set to 2012-10-08.
    200 Config set to dailybck.
    501 Host amanda is not in your disklist.
    Trying host xxxxxx.xxxxxx.xxx ...
    501 Host xxxxxx.xxxxxx.xxx is not in your disklist.
    Trying host xxxxxxx ...
    501 Host xxxxxxx is not in your disklist.
    Trying host xxxxxx.xxxxxx.xxx ...
    501 Host xxxxxx.xxxxxx.xxx is not in your disklist.
    Use the sethost command to choose a host to recover
    amrecover> setdate 2012-10-04
    200 Working date set to 2012-10-04.
    amrecover> sethost localhost
    200 Dump host set to localhost.
    amrecover> setdisk /testbckfiles
    200 Disk set to /testbckfiles.
    599 index file not found
    amrecover> listdisk
    200- List of disk for host localhost
    201- /etc
    201- /netwareShare/nw-logs-b/database
    201- /testbckfiles
    201- /windowsShare
    200 List of disk for host localhost
    Last edited by marmu; October 8th, 2012 at 05:38 AM.

  4. #4
    Join Date
    Aug 2012
    Posts
    81

    Default

    Is your client and server the same machine?
    Were you trying to do amrecover on the server?

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •