Results 1 to 3 of 3

Thread: the problem with compression

  1. #1

    Default the problem with compression

    So I understand that compression is a bad thing, so I'm trying to disable it. On CentOS 5.4, and using an HP MSL2024 Tape Library, I'm trying:

    # mt -f /dev/nst0 compression 0
    /dev/nst0: Input/output error


    And also trying to disable the default compression setting using:

    # mt -f /dev/nst0 defcompression 0


    Any advice on the first error?

    Yet the same commands return no error when used against a single Dell PowerVault (Quantum LTO4 ULTRIUM) drive.

    More food for thought, I also created /dev/stinit.def as follows:

    # cat /etc/stinit.def
    manufacturer=HP model = "Ultrium 4-SCSI" {
    mode2 compression=0 blocksize=0
    }
    manufacturer=QUANTUM model = "ULTRIUM 4" {
    mode2 compression=0 blocksize=0
    }


    and ran:

    # stinit -f /etc/stinit.def -v /dev/st1
    # stinit -f /etc/stinit.def -v /dev/st0


    in an attempt to create devices with compression disabled and blocksize=0

    Hoping this would work, when I tried to create a new amtapetype, I got the following warning that compression is still enabled:

    # amtapetype -c -t HPLTO4 /dev/nst0l
    Applying heuristic check for compression.
    Wrote random (uncompressible) data at 45361118.4262295 bytes/sec
    Wrote fixed (compressible) data at 70949441.6410256 bytes/sec
    Compression: enabled
    Turn off compression or run amtapetype with the -f option


    My version of mt doesn't allow me to view the current device settings:

    # mt -v
    mt-st v. 0.9b


    And it appears that it's not really changing them the way I expected it to.

    I'm confused by the whole compression thing, and feel like a need the big picture. Any advice appreciated!

    -pkb

  2. #2
    Join Date
    Aug 2008
    Location
    Sunnyvale, CA
    Posts
    306

    Default

    I am most familiar with the device name used being what turns on/off compression. What do you get if you drop the "l" and run:

    # amtapetype -c -t HPLTO4 /dev/nst0

  3. #3

    Default

    I tried that first and got the same response about compression still being enabled - even after I issued the command: "mt -f /dev/nst0 compression 0"

    Here's the output:

    # amtapetype -c -t HPLTO4 /dev/nst0
    Applying heuristic check for compression.
    Wrote random (uncompressible) data at 43080250.7540984 bytes/sec
    Wrote fixed (compressible) data at 69155139.368421 bytes/sec
    Compression: enabled
    Turn off compression or run amtapetype with the -f option


    Since I got this output regarding compression still being enabled, *after* trying to force the compression off, that's when I tried creating the other devices with stinit...

    I'm probably missing something basic, so feel free to offer any and all thoughts!

    -pkb

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •